Is my K&N filter causing the black smoke from my exhaust?

Our tech guru has the answers to your car questions
by Ferman Lao | Jun 20, 2013

Dear Ferman,

I own an old, diesel-powered Hyundai Accent. I've had a RaceChip on it for some time now, and I've set it to the most powerful setting that I could before the "check engine light" came on. I recently bought a K&N filter for it.

After I installed the filter, I noticed that black smoke would come out of the exhaust whenever I revved the engine past 3,000rpm. When it happens on the road, a thick cloud of black smoke appears and the vehicles behind me would slow down. I tried putting back the stock filter, but the problem persists. I asked around in the forums, and they told me that the K&N filter has oil that may have leaked into the wire of my intake sensor, and that has been causing the problem. Are they correct? Should I put back the stock filter?

Smoking Hyundai


Dear Smoking,

I doubt that the installation of the K&N filter is the cause of your problem. I also doubt that it "leaked" any oil and contaminated your filter. If the filter was new when you bought it, the amount of oil on the filter pleats would've been just the right amount without any excess.

What you probably read from the forums are from car "geniuses" who excessively oiled their filter after they cleaned it. In such instances, what they described might possibly happen but only on engines using a mass airflow meter. They have an exposed heated wire, which is used to measure the amount of air coming in based on how much energy is used to keep the wire "heated." Should the wire get contaminated by dust, dirt, oil or other contaminates, then it will give a false reading, which the ECU will interpret as a whole chunk of air getting to the engine. The ECU will then send the appropriate amount of fuel based on that information. This may possibly cause you to consume more fuel, but unlikely to the extent that you've described it.

Continue reading below ↓

I would be more inclined to think that whatever parameters you've set your power chip at, it is inappropriate for your engine. I'm assuming that you've likely not had your car tuned on a dyno and you've just set your chip via a seat-of-the-pants method. Unfortunately, the intuition of most people can't tell the difference between a 1hp and 10hp increase in power with certainty. More often than not, the cars that feel fast to the average driver actually show low power on the dyno--in fact, oftentimes, even less than stock.

The best way to find out if your RaceChip has been causing the problem or not is to remove it. If the black smoke goes away, then I suggest you have it dyno-tuned when you reinstall it. If the problem doesn't go away, then I suggest it's time for you to visit a qualified diesel center. It's possible that whatever you've inappropriately had your RaceChip set at, it may have caused some problems that only a diesel center with proper equipment can diagnose to find out in more detail what could have gone wrong.

Unfortunately, you've encountered firsthand one of the common pitfalls of end-user adjustable mods. Without proper tuning at a qualified tuning house or know-how on how to make the proper use of it, you risk damaging your car, which may potentially cost you an arm and a leg in repair costs.

 

Dear Ferman,

I'm a big fan of Top Gear Philippines and I buy your issue every month. I really enjoy reading your column, as it is one of the best sections of your magazine. I wrote to ask your advice on my problem with my 1995 Honda Civic with a B16A lump inside. It sometimes stalls, especially when I'm in first or second gear. The car seems like it's hiccuping.

Continue reading below ↓

In your article in the January/February 2006 issue, you mentioned the idle control valve. Is this the culprit? I already changed the ignition coil, fuel pump and the spark plugs as per my mechanic. Please help me. I don't want to sell my first car.

Thanks and more power!

Ed Jolo Jr.


Hi, Ed. I'm not sure which column of mine you are referring to, but I'm pretty sure I hadn't started Motormouth by January/February 2006.

Anyway, the idle control valve is a possible culprit, but from your description, there's not much more I can tell you without doing a road test on the car itself.

I would advise that you seek a second opinion from a different and perhaps more knowledgeable mechanic than the one you're seeing now.

 

Best regards,

Ferman Lao
Technical Editor

Do car problems keep you awake at night? Send questions to topgear@summitmedia.com.ph.

WE RECOMMEND
MORE FROM THE SUMMIT MEDIA NETWORK
SPONSORED CONTENT
  • Quiz Results

  • TGP Rating:
    /20

    Starts at ₱

    TGP Rating:
    /20
    Starts at ₱